Watch buttons not working


#1

I have a Pebble Steel, and the “right-hand” (up/select/down) buttons do not reliably work properly.

The “down” button always works (as does the “back” button on the “left” side of the watch). The select and up buttons only work if I first press the down button (which performs the down action.) after I “wake up” the watch by pressing the down button (the back button does not “wake up” the buttons, though it functions properly), I can use all three nav buttons properly for a short period of time, until I let the watch alone for a bit; at which point the up and select buttons stop working again, until I press the down button. This behavior occurred on the pre-Time firmware, and also occurs on the v3.9.2 Time firmware. It has survived hard resets as well.

Is there anything I can do about this odd behavior? I can work around it in most apps, but a couple of apps I have do non-reversible things if I hit the Down button.


Button issue or software lag?
#2

I haven’t had the exact same experience, but after about 4 months of use, the Back button on my PTS started sticking.

I contacted pebble support and they replaced the watch.


#3

Hmmph - I’ve had this watch over a year and a half. I’ll try contacting support, but it’s well out of warranty


#4

Exact same problem! Started happening shortly before Timeline update. I’m wondering if this is somehow software instead of hardware. Having to hit the down button first every time is getting annoying.


#5

Support said it was a hardware issue, and that I was out of warranty


#6

I have the exact same behaviou on my Pebble Steel as Jonathan Hurley: the Up and Middle button don’t work, until I press the down button, then sometimes they work for a short while.
I then reinstalled the old firmware, but the setup doesn’t finalise, because now I’m not even able to pair it anymore, since you need to confirm the pairing request with the Up button!!!
The pebble app then pushes a firmware update, asks again to confirm the pairing, but since the up button doesn’t work…
Now I’m stuck with a little brick on my wrist.


#7
I had the same issues luckily within warranty.

My Pebble Steel is not a year old and I had this problems.

Since I had a look on the internal design of the Pebble Steel, I don't think it will take another year until I get the Button-Problem again. The Developers took a zebra-band and put the button-electronics on it. It looks like every time you push the button - especially the "UP" Button - the zebra-band will be pushed too.... and gets broken some day... .-(

It's a hardware problem and has nothing to do with the firmware.

There are some informations about this problem here: https://de.ifixit.com/Wiki/Pebble_Steel_Troubleshooting

#8

Any idea what the Warm Water thing is supposed to do?


#9

I don’t know. Maybe a broken zebraband will work again for some time because the metal in it expands.

I even don’t know why the buttons have to be calibrated (Pushing for 7 seconds…). I mean this is just a simple electronic button with two settings: ON/OFF.

Maybe some one else here could explain this.


#10

From the number of internet posts and videos on this issue, it is starting to look like a common problem. I’ve certainly got an identical situation with having to “wake-up” the Up and Select buttons. Also out of warranty!!


#11

Which is a shame, since I actually prefer the case of the original pebble steel to the one for the pebble time steel


#12

I have exactly the same problem. It seems more like a software bug to me as the top and middle buttons work perfectly once I press the bottom button first. So it is not a sticky/flakey button problem.


#13

Like I said, after some discussion, support said it was an issue requiring hardware replacement, and I was out of warranty.


#14

@ Andrew

the Pebble-Support told me, it’s a hardware problem. I suppose it’s like this: All the buttons are on one zebra-band. If you push the other two buttons, the band will probably get the right position for a working “UP”-Button again.
After pushing the UP-Button for several times the problem re starts.

My new Pebble Steel has the acutal firmware and I don’t have the problem. It can’t be a software issue. Everybody would have this problems, if it would be.

Since my pebble works together with a blackberry, I have to use the “UP”-Button quite often for starting a script mode and using some weather scripts in the blackberry companion app talk2watch. This will probably lead to the same issue again sooner than for other pebble steel owners.

The quality of the pebble is less than average. Design is not for everyone either. I hope pebble will learn something about their mistakes in the past.


#15

Im on the same boat. I dont mind sending this back to Pebble for a repair but seems like theres no straight forward way to have this fixed officially or unofficially.

The ifixit link is a dead end since the author completely missed out saying where to get a replacement zebra cable.


#16

…the same problem again. The only thing I do with the UP-Button regulary: start and stop the timer-app. Now the UP-Button of my Pebble Steel does not work after just 5 month. I still like the watch but I don’t want do push all times the Down-Button just because I want to have a working UP-Button again…


#17

That’s it - I’m off from pebble!

Pebble made me an offer: getting a plastic watch (pebble time black) to solve this button problem (which can not be solved on pebble steel it self). I don’t want plastic watch with a design I don’t like. So I’ve got my second “new” Pebble Steel yesterday. After pushing a button, guess what happend: “Error 0xFE504510” Pebble won’t start at all.

I wasted enough time with setting up watches - I give it back to Amazon. bought it last year for 179,99€, which is a ridiculous price for a watch in this quality. Maybe I buy another pebble steel second hand for 50€, which is a correct prise for software and community.

I’m quite upset because service and quality is not like it should be. This destroyed a product with some good characteristics.


#18

I have 100% exactly the same problem. I love the button idea… so I can press functions with gloves on in the cold, BUT NOT IF THE BUTTONS DON’T WORK!!!

I had the origional pebble - the screen went faulty, pebble replace it… ty pebble. I then sold it and got a steel. I bought it unused from ebay, so effectively new. That was december 2015… It’s been working fine for ages… but now the steel buttons are faulty. So yeah, they’ve lasted 9 months. You would have thought that the buttons, being the unique selling point of the smartwatch, would work for ever more.

I had a casio waterproof watch as a kid… and the buttons never broke… they still work 3 decades later… so what’s the deal?

Please advise pebble. Thank you.


#20

Hello
In one russian forum we’ve found a solution of this problem.
The problem is in the broken wire. All buttons have a common contact on the one side of the watch. And I think this contact is the ground contact of the buttons but not the watch.
In normal state these contacts are connected with a right side of the watch (with the connector) and for example with a small circle on the right. But when the line is broken this buttons don’t work. when you press the down button the contact in the wire restored for a small time. But then it stops working again.
For repairing you need the small wire and very thin soldering iron.
if you look at the picture you’ll see how to fix it.
It’s a 100% solution.
I’ve repaired my Pebble Steel and now it works fine.



Which pebble should I buy in 2017 DONE
Anybody in/near Seattle know how to microsolder? Pebble Steel button repair
#21

Well that sucks. I don’t have a soldering iron. And other way to do this without?